CentOS 8 이 정식 릴리즈 된지 어언 이틀이 지났네요~
여러 엔지니어분들 께서 테스트하기 정신없을 이 시점에 CentOS 8 에서 더이상 사용하지 않는(deprecated)기능에 대해서 알아보겠습니다.

그중 필자가 느끼기에 가장 큰 것은 network script 가 더 이상 사용되지 않는다는 점이다.

CentOS 8 부터 새로운 버전의 ifupifdown 스크립트를 제공하나 이는 nmcli 명령을 통해 NetworkManager를 호출하는 방식으로 제공되어 NetworkManager가 반드시 구동되고 있어야 합니다.

ifupifdown 명령어를 사용하기 위해서는 network-scripts 패키지를 설치하면 되지만
해당명령어를 사용했을 시 경고메시지를 출력합니다.(한마디로 불가피한 상황이 아니라면 사용하지 말라는 이야기이다.)

network-scripts 설치

yum install network-scripts

ifup 명령 실행시 경고 메시지

# ifup ens3
WARN      : [ifup] You are using 'ifup' script provided by 'network-scripts', which are now deprecated.
WARN      : [ifup] 'network-scripts' will be removed in one of the next major releases of RHEL.
WARN      : [ifup] It is advised to switch to 'NetworkManager' instead - it provides 'ifup/ifdown' scripts as well.

그 외에 몇몇 kickstart 명령어들, TLS 1.0 과 TLS 1.1등 몇가지 내용들이 있으니 자세한 내용은 다음 링크를 참고하시길 바랍니다.

더불어

CentOS 8 에서 삭제된 보안 기능들에 대한 자세한 내용은 아래 링크를 참고 하시면 됩니다.


0개의 댓글

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다